Composer ⚡

Check-out the package homepage on packagist.org.

The current composer.json file:

{
    "name": "strangebuzz/microsymfony",
    "description": "A template to initialize an application to use Symfony as a micro-framework",
    "license": "MIT",
    "type": "symfony-application-template",
    "keywords": [
        "micro-framework",
        "php",
        "poc",
        "project-template",
        "rad",
        "symfony",
        "web-application"
    ],
    "homepage": "https://microsymfony.ovh",
    "require": {
        "php": ">=8.2",
        "ext-ctype": "*",
        "ext-dom": "*",
        "ext-iconv": "*",
        "ext-libxml": "*",
        "ext-simplexml": "*",
        "ext-xml": "*",
        "league/commonmark": "^2.4",
        "symfony/asset": "~7.0.0",
        "symfony/asset-mapper": "~7.0.0",
        "symfony/console": "~7.0.0",
        "symfony/dotenv": "~7.0.0",
        "symfony/flex": "^2",
        "symfony/form": "~7.0.0",
        "symfony/framework-bundle": "~7.0.0",
        "symfony/http-foundation": "7.0.*",
        "symfony/http-kernel": "7.0.*",
        "symfony/intl": "~7.0.0",
        "symfony/monolog-bundle": "^3.8",
        "symfony/routing": "7.0.*",
        "symfony/runtime": "~7.0.0",
        "symfony/stimulus-bundle": "^2.0",
        "symfony/string": "7.0.*",
        "symfony/twig-bundle": "~7.0.0",
        "symfony/validator": "~7.0.0",
        "symfony/web-link": "7.0.*",
        "symfony/yaml": "~7.0.0",
        "twig/extra-bundle": "^3.0",
        "twig/markdown-extra": "^3.7",
        "twig/twig": "^3.0"
    },
    "require-dev": {
        "bamarni/composer-bin-plugin": "^1.8",
        "phpstan/extension-installer": "^1.3",
        "phpstan/phpstan-symfony": "^1.3",
        "phpunit/phpunit": "^11.0",
        "roave/security-advisories": "dev-latest",
        "symfony/browser-kit": "~7.0.0",
        "symfony/css-selector": "~7.0.0",
        "symfony/requirements-checker": "^2.0",
        "symfony/stopwatch": "~7.0.0",
        "symfony/web-profiler-bundle": "~7.0.0"
    },
    "replace": {
        "symfony/polyfill-ctype": "*",
        "symfony/polyfill-iconv": "*",
        "symfony/polyfill-php72": "*",
        "symfony/polyfill-php73": "*",
        "symfony/polyfill-php74": "*",
        "symfony/polyfill-php80": "*",
        "symfony/polyfill-php81": "*"
    },
    "conflict": {
        "symfony/symfony": "*"
    },
    "minimum-stability": "stable",
    "prefer-stable": true,
    "autoload": {
        "psr-4": {
            "App\\": "src/"
        }
    },
    "autoload-dev": {
        "psr-4": {
            "App\\Tests\\": "tests/"
        }
    },
    "config": {
        "allow-plugins": {
            "bamarni/composer-bin-plugin": true,
            "php-http/discovery": true,
            "phpstan/extension-installer": true,
            "symfony/flex": true,
            "symfony/runtime": true
        },
        "sort-packages": true
    },
    "extra": {
        "bamarni-bin": {
            "bin-links": true,
            "forward-command": true
        },
        "symfony": {
            "allow-contrib": false,
            "require": "7.0.*"
        }
    },
    "scripts": {
        "post-install-cmd": [
            "@auto-scripts",
            "@composer bin php-cs-fixer install --ansi"
        ],
        "post-update-cmd": [
            "@auto-scripts"
        ],
        "app:test": [
            "vendor/bin/phpunit"
        ],
        "auto-scripts": {
            "cache:clear": "symfony-cmd",
            "assets:install %PUBLIC_DIR%": "symfony-cmd",
            "requirements-checker": "script"
        }
    },
    "scripts-descriptions": {
        "app:test": "Run all PHPUnit tests"
    }
}